[SOLVED] Custom editor within array - TypeError: Cannot read property 'valueChanges' of undefined

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I have a scheme with an array, I added a custom editor url to one of the field within the array. As soon as I open the content section of this scheme (single content) the console prints lots of errors: ERROR TypeError: Cannot read property ‘valueChanges’ of undefined.

I also tested my custom editor within a regular field (not within an array) which is working fine. I know this scheme setup has worked before but not anymore.

Expected behavior

I would expect that the custom editor would also work within an array field.

Minimal reproduction of the problem

Create a scheme with an array field and add a field within the array (String) with a custom editor url. For example:https://squidex.github.io/squidex-samples/editors/cke-simple.html. Now go to the content section of your scheme and the custom editor will not load correctly.


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge



Which version do you use?

The cloud version, I forgot to edit that …

1 Like

I have fixed it and will deploy it on Monday.

Great! Thanks for the quick response!

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.