[SOLVED] Contents view results per page not saving

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [x] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When you’ve changed the number of Contents results per page, navigate away and go back to that page the number defaults back to 10.

Changing the value from 10 to 50:

After navigating away and coming back again:

Expected behavior

The number of results I have selected persists between pages.

Minimal reproduction of the problem

  1. Open contents view for a schema.
  2. Change value of


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: 7.8.1 & the current cloud version if not the same


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [x] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Was working as of 7.2.0, sorry I cannot narrow down the version where this was introduced!

Oddly it does seem to be saving it when you click “Content” and then select a schema. it’s only when selecting a schema directly from the panel without clicking “Content” first that the value is defaulted back to 10. Image below to clarify what I am talking about.

Note: Did quickly check Assets and that seems to be working fine, but it doesn’t have that side panel.

I will have a look. I have a dejavu.

I don’t see any code that would save the page size :smiley:

Sorry, I was wrong. But I cannot reproduce it.

Hi Sebastian.
Here is the recorded issue that is mentioned above. Note that this is recorded in Edge. https://gifyu.com/image/SgpI9

1 Like

Ah can we not upload gifs? Edit: Tried myself but it got stuck on “Uploading 100%”.

Yes, i can reproduce it now


Is this the commit that fixes it? https://github.com/Squidex/squidex/commit/533daf1c54e5cd167fb9717d2e58800275ca9e06
If so thanks and I look forward to next release!

Yes, it is. Can you try the dev tag?

Tried to save time and use Docker but it’s not working for me and I am out of time! Will ask on Friday if anyone else has run it locally and if not can request that fix be deployed to shared environment.

I meant just to use the dev tag dev-7662

Have to confess that in all this time I have never one targeted a dev tag; do you mean pulling down using that tag instead of a release tag?

1 Like

Yes, just use squidex/squidex:dev-7662

This topic was automatically closed after 2 days. New replies are no longer allowed.