[SOLVED] Contents not showing up in editor sporadically

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Within the content editor, when navigating between different contents, they sometimes does not show up and editor UI stays empty such if there were no contents added yet, even though there are items in the database and also coming back from the server when looking into the network panel.

After a hard reload of the page the contents show up normally.

Expected behavior

If there are contents added and returning from the backend, I’m expecting them to be filled into the editor GUI. I’m sure this is a frontend issue only, as the server seems to deliver contents just fine (see attached screenshot)

Minimal reproduction of the problem

  • I can provide a backup and/or my docker-compose.yml for easy reproduction if necessary.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 5.3


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [x] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


  • I also tried the latest “dev” tag but the issue still occurs.
  • There are no errors on the chrome console either.

Is it only the array editor?

Hi Sebastian, thanks for your quick response. Yes you’re right, it’s only happening with the array editor, although I cannot provide reliable reproduction steps - it’s really only happening “from time to time” without any error on the console.

1 Like

I think I have a potential fix.The build is currently running but you an try dev-5154 when done: https://build.squidex.io/Squidex/squidex/5154

Thank you Sebastian for providing such a quick fix for this issue. Just wanted to let you know that it’s resolved now and I cannot reproduce the issue anymore. Keep on the great work on Squidex :+1:

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.