[SOLVED] Content with separators cannot be saved


#1

Hi Sebastian

Played around in my sandbox environment ( App Service and CosmoDB ) to test out the latest changes in master branched, i’ve switched over to dev docker image, to test out the new UI content separator.

For some reason it got slow and throw some errors, which since it’s in dev is expected. However i tried then to switch back to latest, and then things start to break because now UI separator of cause is not recognized by the code, which again make sense.

But this got me thinking, when we/you upgrade to a new version does it then alter the document store? and in case of a need of a rollback what is the best procedure?


#2

There is no good procedure yet. You could delete everything except the events and then use some commands (enabled by settings) to rebuild the other stores: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L429

But I have deployed the UI content separators to the cloud and have not experienced any issues.


#3

Okay thanks, what docker image are you using in production? I could be due to CosmoDB maybe, i will check it out.


#4

I just quickly added two UI separators on production get similar issue, so it seems like there is something not working completely as intended.

Maybe i should report a bug instead?


#5

Looks like a bug with validation. I use a custom image in the cloud because it has some plugins for billing and so on.


#7

I pushed a fix for the saving error.


#8

The fix is also deployed to the Cloud.


#9