[SOLVED] Content items disappearing when too many are linked

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When linking a lot of content items on a reference field (about 100 seems to be the threshold), they are saved as expected at first, but when revisiting later (the time did not seem to be consistent, but from what I could reproduce about half an hour at most) the field is empty. When revisiting right after saving, even from another machine with another user, the linked items are shown as expected.
There is no limit set for the field in question and I got no error or warning message, the field just got cleared.
Also the change history did not track the added items, it just shows a change from empty field to empty field.
This happens when adding 100+ items at once as well as when adding them in batches (after adding items 90-110 it clears all entries, not just the latest ones).

Expected behavior

If no upper limit is set, as many items as desired can be linked to a reference field and stay linked.

Minimal reproduction of the problem

Create a reference field and try to link more than 100 items, then wait about 30 minutes and check if the linked items are still present.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Thanks for the bug report and welcome to Squidex. I will have a look.

I cannot reproduce it. Are you sure you have not done anything else?

Yes, it is a pretty simple object and I just assigned values for a reference field.
Tried to reproduce it again after seeing your reply and it still has problems, behaving a bit differently from before though…

This time it took longer (can’t pin it down exactly unfortunately, but somewhere between 1,5 to 2 hours)

Also, the field was not cleared completely. I tried different approaches for seperate instances of the object

  • For one I assigned 90 items before (after initially posting the bug report), to see if they might be cleared later (which was not the case) and added some now. The old entries were kept, but all additional ones have been removed again.
  • On another, initially empty one, I added about 160 items, 10 at a time while saving after each batch. Here the first 110 entries are still present, the later ones have been removed too. (As I initially tried this approach, before posting the report, the field was emptied completely).

I am quite confused with this inconsistent behaviour…

In any case, thank you for looking into this and the quick response

I will dig deeper into that. Which version do you run?

Running 4.0.3 - sorry, totally missed that part in the original report

1 Like