[SOLVED] Backups can no longer be restored

Hey there,

with the Update to 6.8.0 we were no longer able to restore backups from our production CMS app. Unfortunately the logs did not really have any useful information and I couldn’t find anything here that resembled the issue, so I decided to take matters into my own hands and started debugging.

I found out, that with large backups, it happens quite often that the content restore ends up trying to emit 0 events in MongoContentRepository_SnapshotStore which will throw an error in the current version of the mongoDB driver.

My assessment would be, that it’s generally a non-error if there is no content inserted and the exception that is thrown by the mongodb driver can just be avoided without other errors being swallowed by the fix.

I posted a pull request for my suggested fix on github: https://github.com/Squidex/squidex/pull/895

Have a nice day!

Thanks, there are probably more places like the one you found.

Should be solved now.

This topic was automatically closed after 2 days. New replies are no longer allowed.