[SOLVED] Assets can not be managed via UI

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [x] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When I upload an asset (image) via the Squidex UI and refresh the page (after the image is uploaded) the asset is not visible anymore in the UI.
If I re-upload the same image after that I get the validation error: “Asset has already been uploaded” (so the image is uploaded but not visible in asset explorer)

When I upload an image via an asset field of my custom schema I even can not upload the image, instead, I get a validation error: “parentId: Asset folder does not exist”

Expected behavior

Assets can be managed with the UI.

Minimal reproduction of the problem

First of all thank you very much for this awesome headless CMS.
I am using squidex:5.1.0 with docker.

I have made no custom configurations to Squidex (especially no customizations to asset storage configuration).
I used the docker-compose from: https://github.com/Squidex/squidex-docker/blob/master/standalone/docker-compose.yml


  • Start Squidex with docker-compose using https://github.com/Squidex/squidex-docker/blob/master/standalone/docker-compose.yml

  • create app named “test”

  • login to Squidex UI

  • upload an image (Asset) and wait until it is uploaded => image available

  • refresh the page by pressing F5 => no images available

  • try to re-upload the image => validation error: “Asset has already been uploaded”

  • upload image via asset field in a custom schema => validation error: “parentId: Asset folder does not exist”

The issue occurs in 5.1.0 , 5.1.1, but not in 5.0.0


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: squidex:5.1.0


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [x] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Thank you for the good bug report. I can reproduce it and will provide a fix today.

1 Like

It is solved in 5.2.0

Wow, thank you for the quick solution. I can confirm with 5.2.0 managing assets via Ui is working as expected.

There is still the other issue with asset fields, maybe this was not clear enough described.

  • create app named “test”
  • login to Squidex UI
  • Create and publish a new schema named myschema
  • add an asset field named background-image
  • create new content with schema myschema
  • upload an image to the background-image field (via drop file) => validation error: “parentId: Asset folder does not exist”

I can also confirm this. Sorry, the 5.0 includes so much internal changes due to the new ID stuff.

EDIT: Build is on the way.

1 Like

Many thanks again, tested version 5.2.1, and also the asset field is working now how expected.

1 Like