[SOLVED] Åäö and other non-english chars in autogenerated slug

Not sure if this is a bug or if I’m doing something wrong but I’ve tried several configurations and can’t get it to work. The autogenerated slug is having a hard time creating itself using non-english chars. Is there a topic on this someplace else, or how can I make this work?

What do you mean with auto-generated slug? Do you mean the slug field?

Yes. Reproducible by using the blog template.
For example It converts ö to oe which is wrong.
I guess the slugify method tries to do an educated guess but in my case this is wrong.SEO will get punished.

Why is this wrong? I guess you are also german. I never had problems with “oe” in URLs and SEO.

It is a static table: https://github.com/Squidex/squidex/blob/master/src/Squidex.Infrastructure/StringExtensions.cs at the moment.

No, swedish.

This is how it should be.

åäö => aao

Who defines that? :wink: For german ‘Ä’ translates much better to AE and everybody in Germany would agree to that. For Swedish you are probably right.

I added a parameter to the slugify method:

The slug is generated through scripting: https://docs.squidex.io/guides/scripting

You can just add a parameter true to slugify, e.g. replace slugify(value) with slugify(value, true).

I will deploy it today.

No one, really, but after years of googling and surfing swedish sites that’s the most common way I’ve seen site owners do it.
Lovely, thanks for the quick response.

It is deployed, can you help me testing it?

Need to update image in cluster. Let you know when done.

redeployed pod with new image.

seems to be working now.

I added true to the slugify method like you said.

Great. I will close this topic now.