[SOLVED] 415 Unsupported Media Type when using GET graphql query

I have…

  • [x] Checked the logs and have provided the logs if I found something suspicious there

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Likely that I’m just missing some header here (so could be that this is not an actual bug report, but my fault): when executing a GET request to query against the graphql endpoint I get a 415 (Unsupported Media Type) status code.

With POST everything works fine - however we need GET to be able to cache requests using the Squidex content CDN (as per the Squidex CDN caching documentation).

Expected behavior

GET works as well as POST.

Minimal reproduction of the problem

Just run a GET request with a query against the graphql endpoint, e.g.

https://cloud.squidex.io/api/content/clear/graphql?query=<urlencoded query>

The headers are:

Accept: application/json
RetryWithRefresh: true
Authorization: Bearer xyz
X-Languages: en-US, en


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: latest (cloud)


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge
  • [x] Android
  • [x] iOS

We are using the Apollo GraphQL library on Android and iOS to create and execute the requests.

I cannot reproduce it, are you sure that Apollo does not add change the URL or so?

Hm, I’ve copied the above URL from a network sniffer - so it’s the actual URL. Can I send you the full request via some confidential means? Maybe it’s something about the encoding of the query?

Ofc, just send me a PM.

Quick update here for everyone who might be following this issue: the source has been found and fixed by @Sebastian and there are just a few tests to be written before deployment. :slight_smile:

@Sebastian any idea when this will roughly be merged?

I hope today, it is merged and tested already.

1 Like

@Sebastian Interestingly we found that for certain graphql requests we still receive errors when using GET. In this case a 500, not a 415. I’ll send you the request via DM.

Okay, I will test it with your query.

1 Like

Fix is in the build pipeline.

it is solved. Took a little bit longer, because I had to cleanup the build server.

1 Like

Great news, many thanks for the quick fix! Works perfect on our end as well! :pray:

1 Like