[SOLVED] 2019-09-19 Schema and Content is Gone

Hi, we have an error today with our site with the message - Squidex.ClientLibrary.SquidexException: The app, schema or entity does not exist.

Upon checking and logging into the UI, we only have one schema available. I dont see our other schemas. Can you guide me on how to check the logs on why it happened?

Also do we have a restore procedure that we can use? I see from our logs that the first report happened 3:15 AM GMT+8 Time.

Are you talking about self hosting or cloud? Have you recently updated the version, e.g. to dev?

Where are you hosting?

Hi Sebastian,

We are using cloud, and the content is hosted under Squidex. We havent updated anything (Last update was August 22)

Okay, it seems that some indices are corrupt. I will recreate them and see if it solves the issue. Will get back to you in a few minutes.

Thank you Sebastian! We will wait for your update.

Indexes look okay now, but it does not seem to solve the issue. I will debug it locally and update you asap.

Thanks Sebastian! We appreciate the assistance


I’ve got exactly the same problem. Posting to follow this issue!

Kind regards
Lode Kennes

I have found and solved a bug in the indexer. I have fixed it and it is in the CI pipeline now. I will deploy it asap and keep you updated. Sorry for the inconvenience.

1 Like

I think the error is fixed. Can you please have a look to your schemas and verify it? I will write a postmortem after that.

Hi Sebastian, I can confirm that this fixed the missing info. Thank you for the assistance!

Also to add, is there a way that we can download a backup of the schema, etc so in case this happens at least we have a backup that we can use?

You can use the backup system for that, but the schema was never gone, it was an indexing problem. I will explain the reasons in the post mortem.

See: 2019-09-19 Schema and Content is Gone: Post Mortem

We are still experiencing this issue, the schemes are fine, but all the content are gone

content pages return either 429 or 404 errors

Can you give me an example request and app name + schema name?

Do you get the error only from the API or also the UI?

Both, the request is https://cloud.squidex.io/api/content/reuring/content-footer?q={"take"%3A10%2C"sort"%3A[]%2C"filter"%3A{"and"%3A[]}}

edited: sorry I can only reply max 3 messages per thread. Thanks the problem is solved!

Do you remember if you have every recreated this schema?