[PARTIALLY_SOLVED] 4.2.0 Beta Hiccups

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Assets cannot be deleted…

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [x ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [4.2.0-beta1]


  • [x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


What happens, in my current master it seems to work.

Still doesn’t work in Beta 2. What log’s would help you- the one from the sites, or the one from IIS?

I’ve tried recursive delete true and false…

A little more infos like “does not work”…what are you actually doing? Do you see any error logs in chrome or Squidex? Do you have WebDAV installed on your IIS server?

1 Like

WebDav not installed- New assets can be deleted, My users are saying older assets they uploaded cannot- I’m getting a list from them and will test it myself shortly. Thanks again so much.

It was a permissions problem. During an upgrade, permissions on custom roles got messed up

There is some sort of issue with adding and saving permissions

then saving, it looks like:

There is a bug! In grid view, the content deletes. In list view, the content does not delete.

I have fixed that as well.