Option to turn off fallback language?

I’m submitting a…

  • [ X ] Regression (a behavior that stopped working in a new release)

Current behavior

For news articles on our website, we had the rule; If slug is empty in a language, we wont show this article on that particular language. This feature works for non-master languages. But since fallback is introduced. We can’t use this rule if we have a news article which should only be shown in the master language. Because fallback fills out this data for us in the other languages.
See image as an example. Page “voorkeur-monteurs…” should be NL only. Just like the page “duerfen-wir…”. But because NL is our fallback language, the slug is copied to all languages.
Is there any way to surpass this setting? Other than adding a boolean “Show on this language” on this schema?

Expected behavior

An option to turn of fallback maybe?

Minimal reproduction of the problem

Environment

  • [ x ] Cloud version

Others:


App: app/jeveka/content/news-page?take=10
If you need anything, please let me know.

Why is this a bug report?

Except that: There is a header X-NoResolveLanguages=1 which can be used.

Ah ok. I’m looking in to that. Thanks!