[OBSOLETE] Issues with our Import / Export Routine

Hi there,

Was there any deployments Friday/Over the weekend at all. The export routine seems to have stopped working (as it was on Thursday).

Error with import/export functionality

  • export from cloud instance and import into hosted instance now fails if default app exists

2018-11-12T09:05:00Z: Started. The restore process has the following steps:
2018-11-12T09:05:00Z: * Download backup
2018-11-12T09:05:00Z: * Restore events and attachments.
2018-11-12T09:05:00Z: * Restore all objects like app, schemas and contents
2018-11-12T09:05:00Z: * Complete the restore operation for all objects
2018-11-12T09:05:00Z: Downloading Backup
2018-11-12T09:05:04Z: Downloaded Backup
2018-11-12T09:05:04Z: The app id or name is not available.

I’m submitting a…

[x ] Regression (a behavior that stopped working in a new release)
[x ] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [x ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x ] Cloud version


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


I have deployed the new permission system this weekend and a few minor bugfixes. I will have a look to it this afternoon. It would be helpful if you can provide me a link to your backup.

What I do not understand is the following sentence: "if default app exists” … what do you mean with “default app”? A name with the same name or a different name?

Where do you export and where do you import?

I have backuped my squidex-website app and restored it locally and it worked for me…

We are still having issues and so I am going to have our Lead Dev, provide you with the details of what exactly isn’t working.

Thanks Sebastian,


Hi Sebastian,

I’m following from where @Jace_Smiffy left off:

We have a hosted environment of Squidex. When restoring an export from the cloud-hosted version of Squidex and imported into this hosted environment we experience an error if no app name is provided.

  • If we provide a name for the application and it does not already exist then the restore works fine.
  • If the app exists and we try to restore over it the restore fails.

That is not a bug. Squidex never deletes data. You have to delete your previous app if you want to create a new app.

But I solved a small issue when with the app name input.

1 Like

Thank you for the rapid response @Sebastian. So I guess we need to upgrade to the latest release?

However, I personally thought I was able to over-write the app on a restore. I may have been mistaken.

Then the bug is that this is possible :wink:

lol - let us assume it is. Would you be able to verify & if confirmed is it something on your roadmap to fix?

We are likely to upgrade our hosted version at some point in the coming week or so.

So far there is no known bug for the backup and restore process. Usually I fix bugs as soon as possible. So if you can reproduce the bug today it is very likely that it is fixed until tomorrow

Closed due to inactivity.