[OBSOLETE] Better error when the upload payload is too large


#1

I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[ ] Bug report
[ ] Performance issue
[X] Documentation issue or request

Current behavior

When uploading a file that’s too large (where can I configure the size?) – it will fail with a generic error.

Expected behavior

The error should explain that the file is too large.

Minimal reproduction of the problem

Try to upload a 30MB file.

Environment

  • [X] Self hosted with version docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Browser:

  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:

Return status: “413 Payload Too Large”


#2

Mhm, I get the following message in the UI and in the API:

I also added the options to the config file: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L86


#3

I’ll pull latest and test again! Thanks for adding that configuration item.


#4

If you are self hosting and have NGINX, the default payload size is 1 mb. You will have to update NGINX to allow larger files.


#5

Good point. Do you know the setting? would be great to add it to our docker-compose files.


#6

I believe it is client_max_body_size 5m for a 5 mb limit


#7

@Jaben What is your status for this item?


#8

I still get the same error “failed to make the request” with this in the console:


#9

This is definitely not squidex :wink: … But even though I can improve the validation message for a 413


#10

Okay – I’ll check with our infrastructure department and see if it’s related to the proxy (F5).


#11

Hi, I have improved the error message, but I still think that the problem must on your side. You can increase the size here: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L102

The maximum default size for kestrel is 128 MB, I have not changed this.


#12