[NOT_SQUIDEX] Errors with latest -- maybe lacking role migration?


#1

I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[X] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

Won’t startup

Expected behavior

Should startup

Minimal reproduction of the problem

Environment

  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Browser:

  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:


#2

Hi,

it seems that something went wrong with the migration. I have tested it locally and was running it two times successfully in the cloud, but it seems it was not enough.

Can you post the document from the Mongo Database? There is also a Migration collection. Would be great to get the status of this collection.


#3

Migration just has the one:

“State_Apps” has this one:


#4

It should be 12, I am confused why the migration was never running on your deployment.


#5

Not sure either – migration worked perfectly on my development swarm.


#6

Can you restart it and check the logs for the migration process?


#7

Yes, confirmed that its not running migration. I’m not sure WHAT the heck is wrong with it – all kinds of problems. I think I’m going to use the backup and delete the whole thing, than restore it. I’ve tried everything else…


#8

You can just clear the apps collection. It will restore the States_Apps automatically from the events then.


#9

This worked perfectly! In my production instance it magically fixed all the issues with app login and migration!


#10

Great, but I don’t get it why it was not running automatically. I have to test it again.


#11

Sebastian – seriously thank you for your time.

But no need to investigate further – I’ve figured out the problem. We run a shared production replicated mongo instance that gets a lot of traffic from other in-house apps. Unfortunately, it seems writes are basically getting deleted as one of the replicas is “recovering” – causing all kinds of awful and strange behavior.

I put a new instance of mongodb just for our stuff and now have absolutely no issues. Migration happened, rules work again, etc.

Sorry for the confusion… but there was no clear indication the mongodb infrastructure was failing. Once I added a database and it didn’t appear – I knew something was up.

Thanks again :slight_smile: – Squidex is great!


#12

Good to hear, I was worried that I introduced some strange bugs.


#13