[NOT_REPRODUCIBLE] Unable to delete webhook rule

I have issue with deleting webhook rule. Every time I’m trying to delete rule I receive “Rule has been already deleted”, but rule is still here.
The same behavior when trying to update rule or disable/enable it.
Tried to delete it through API - the same result (and Squidex makes the the same requests to API according to dev console).
Response is: {“message”:“Rule has already been deleted.”,“traceId”:"|a6b7b179-4caa1c7b3fe1abab.",“type”:“https://tools.ietf.org/html/rfc7231#section-6.5.1","statusCode”:400}

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

  1. Navigate to Rules
  2. Delete the rule
  3. Got error and rule is not deleted:

Expected behavior

Rule has been actually deleted.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version



  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Are you running Squidex with more than one node?

No, we are not. One node.

You can try to restart, I will have a closer look later. So far I cannot reproduce it.

We did restart, but didn’t work, then we tried to reset event consumers, that seems to do the trick.

I don’t see any relationship to event consumers.

Okay, the problem disappeared over the weekend, and this was the only thing we did active