[NOT_REPRODUCIBLE] Assets are unavailable and new ones arent recognized as images


#1

I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[X] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

Published assets are unavailable, the browser return error 404 on assets published and trying to access to them, assets section on squidex looks like this:


and If i try to upload a new in the content section (directly to the content to publish) it does not recognize it as an image and forbid me to upload

Minimal reproduction of the problem

It was working fine yesterday, I turned on the pc and now I have this, i fixed this once by deleting the project and cloning the lastest Squidex version, installing dependencies etc… but I’m close to publishing and I would love to have a fix other than deleting and reinstalling.

Environment

  • [ ] Self hosted with docker
  • [X] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Browser:

  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

#2

Could be a duplicate of: Issue with v2.0: GridFS Assets Don't Work Anymore

In general it is hard to find the issue with so few information.

Have you used backup or restore or something like this?
Have you checked the logs?
Which asset store do you use?
Where do you store the assets?
In case of docker: Do you have a volume?


#3

Yes, I did used a backup from my mongo dump.
I’m filling this issue for my boss :confused: hehe I’ll ask him for the logs
Default asset store, we haven’t change a thing arround that
Not using Docker.


#4

If you restore a backup you also have to restore the assets as they are not stored in MongoDB by default.


#5

Really? becuase I’ve restored dumps before and always restores the assets. and even if I try to upload any asset it’s really unusable.


#6

Sorry, I just asked for common mistakes. And I cannot reproduce it, especially not that uploading new images does not work.


#7

Can you send me your backup? Perhaps I can debug it.


#8

I can’t :confused: But i Will try to re, restore the dump or just do a whole new set up. I’ll read more on what you say about mongo not restoring assets


#9

Closing this now due inactivity.


#10