My schemes are gone, what to do?


#1

I logged in and it did not log, I tried to use via api and nothing, when I opened the mongo compose to see the schemas he was not there, what to do?


#2

I have no idea how this could happen as Squidex never deletes data. There is not even a delete method.^

But as long as the events are still there everything can be restored. We just need a method for it.


#3

Is there any way to recover this data?


#4

I added a commit with a rebuilder, where you can rebuild the content based on the schemas:

You can enable it in the settings:

See the full commit here:

You can enable it with environment variable: REBUILD__SCHEMAS=true

or you can just run it with dotnet run --Rebuild:Schemas=true (I think)

You can read more about it here:


#5

Even doing what you gave me can not retrieve the schemas / data, any other suggestions?


#6

You can export your database and send it over to me me, so that I can debug through it and have a look.


#7

I’ve remade the compose again!


#8

And it solved the problem?


#9

No, this is very strange!


#10

As I said: Send me your backup and I can have a look. Otherwise it is like a blackbox for me.


#11

Can I pass you the connection string?


#12

If your mongodb is available from the outside, sure


#13

Follow the connection string
https://send.firefox.com/download/ded3fb2439da4045/#_LbAQLJOYryMulBMPe27Lw
Password download: DELETED


#14

Thx, please send it as PM the next time :wink:


#15

It looks like the whole database has been recreated. I don’t know what has happened but this is basically an empty database + 1 user. There is nothing I can do for you.


#16

No problem, thanks for the help!


#17

You are welcome. I am 100% sure, that is not Squidex. Because there is nothing that deletes users or events from the database. The whole concept of Squidex is to never delete data.


#18

Hey @Sebastian,
I am experiencing the same issue. It looks like after I restart my Docker Container something recreated the Database. I can remember to read something about recreating the Mongo Db on the configured folder even if it is not empty.


#19

I am 100% sure that Squidex does not recreate any databases. Do you have a persistence volume for your database?


#20

I mapped an szure storage account as described in my Azure Setup Documentation. For some reason they are all empty. It looks like the MongoDb container does not use it to persist the data.