Maximum number of Schema Instances


#1

HI Sebastian,

We have an issue here on this CMS where we have >200 questions that we are using on our system (using a ‘question’ schema that we have created). It seems to have broken our site, but then after some investigation your documentation suggests that 200 is the maximum I can have. Just wondering why you have set such a small number? This is reducing our functionality and is causing us issues. Can this number be overwridden?

Thanks

jason


#2

You can only retrieve 200 content items at a time. The reason is that I want to protect the cloud. The full text search will also not give you more than 2000 items at all for a particular search.

But you can override it: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L155


#3

Aaaah - that would make sense. We have applied the override and I just need to put it through testing today. Thanks for the rapid turnaround on this - we go live with the product next Wed and already the the media comms promotion program has started. So there is no turning back now :slight_smile:


#4

Hi Sebastian,
Is there a way to override default top/take queries somewhere in the appsettings env values as well?
Please see image, instead of sending top:xx with the queries, like to increase the default page top/take limit there.


#5

Not yet, but it should be easy to implement. PRs are welcome. :wink:


#6

I have added the setting: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L153

And the same for assets.

GraphQL and REST API are a little bit inconsistent here, because the default page size for REST is maxResultsand the default page size for GraphQL is defaultPageSize.

But I decided to keep it like that because I do not want to break existing installations, especially when deploying it to the cloud.


#7

Introduced a second setting: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L157