Issue when trying to run the development environment locally

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [x] Documentation issue or request

Current behavior

I downloaded the code from the Github, and followed the steps here:

For the frontend npm i just didn’t work, it couldn’t resolve the dependencies, so I tried:
npm i --legacy-peer-deps
which was able to build the project, but when I run the project I got an empty browser page with this error in the console: “Application element not found” which is mean Angular wasn’t able to bootstrap the project.

Expected behavior

the frontend build and run on local environment

Minimal reproduction of the problem


App Name: localhost

Angular CLI: 13.1.4
Node: 16.13.0
Package Manager: npm 8.1.0
OS: win32 x64

Angular: 13.1.1
… animations, cdk, cdk-experimental, common, core, elements
… forms, localize, platform-browser, platform-browser-dynamic
… platform-server, router

Package Version

angular-devkit/architect 0.1303.9
angular-devkit/build-angular 13.1.4
angular-devkit/core 13.3.9
angular-devkit/schematics 13.1.4
angular/cli 13.1.4
angular/compiler 13.3.11
angular/compiler-cli 13.1.3
schematics/angular 13.1.4
rxjs 7.5.1
typescript 4.5.5

Version: 7.0.0-rc2


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


How do you run the project? I have the same node version and it works fine for me and also on the build server so I don’t see at the moment what the issue could be.

I’m using npm start to run the project,
the error is happening in AppModule:
caught exception: angular_core__WEBPACK_IMPORTED_MODULE_3_.ɵɵelementStart(…) is not a function


By the way, several of my collogues tried to do the same and get the same error

I am going to delete my node_modules folder and see what happens then.

Works fine for me… what do you mean with For the frontend npm i just didn’t work, it couldn’t resolve the dependencies, so I tried:

What happend with a normal npm i?

Thanks for your patience @Sebastian,
I tried npm i to get a fresh screen shot of the error for you but it worked surprisingly, just don’t know what happened.

Anyway this is a screen shot of the error I was getting yesterday when running npm i:

1 Like

Have you just tried “–force”

No, I tried --legacy-peer-deps, I will try --force if I got the error again

1 Like