Instructions for Getting Started

I landed on the getting started section of the docs page I downloaded the docker setup locally to a mac and ran docker-compose up -d. But the instructions end there. Now what? What is running and where is it running? How do I use Squidex? Note that the “Help for new users” link is broken.

Also, I made wild random guesses as to what goes in the .env file. Am I supposed to make these things up? Are they set up somewhere else? What is the squidex_domain? Any help is appreciated.

Hi Wayne,

have you seen this?

But please not that Squidex does not run on ARM at the moment. You might run into issues.

Yes. Those are the instructions that I mentioned above. I downloaded the docker files, etc and docker is running on my machine. But now what? The documentation “ends” there.

That document is also very unclear as to where I should get the information to populate the .env file.

I am confused. Does the page I have linked does not mention it?

  1. Download docker-compose files.
  2. Set .env vars. Actually only SQUIDEX__DOMAIN is needed, I guess it is localhost in your case. From the docs: “You can keep the other settings empty for now.”
  3. Start it with docker-compose up -d

I’ll try it with localhost. But that’s one of the issues. The documentation doesn’t say what to put in the .env file. How do I know what the SQUIDEX_DOMAIN is supposed to be?

As I mentioned, I already ran docker-compose up -d and it’s running. My question is…Now what?

SQUIDEX_DOMAIN is your domain, e.g. if you own and you want to install Squidex under, then this is the domain name.

As I mentioned, I already ran docker-compose up -d and it’s running. My question is…Now what?

Now you just go to https://localhost

Thats’s what I get at https:/localhost

This is the docker details.

Caddy can only create a self signed certificate for localhost, therefore you see this screen (it should be mentioned in the docs).

But I just tested it and I can accept the certificate and then continue.

I was able to get around the certificate issue. And now I have a squidex window! Thanks!

I would suggest some updates to the documentation to add two things:
SQUIDEX_DOMAIN=localhost // Example if running the installation locally with Docker

After installation, navigate to https://${SQUIDEX_DOMAIN} to launch your instance of Squidex.

I am just working on that right now :slight_smile:

I have added it, thanks for your patient and feedback:

Awesome! Thank you for your help!

1 Like