Install Squidex


#1

I have…

  • [ X] Checked the logs and have provided the logs if I found something suspicious there

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [X] Documentation issue or request

Current behavior

Hello, I’m trying to get the Squidex CMS to work on a Windows Server using IIS but I can’t seam to make it work. I have followed the instructions in “Install with IIS” but, I currently just get the spinner in the middle of the page. If I go to the DevTools of the browser, I get the following message.

ERROR Error: Uncaught (in promise): ErrorDto({“statusCode”:500,“message”:“Failed to load apps. Please reload.”,“details”:[],“displayMessage”:“Failed to load apps. Please reload.”})

when I look at the log on the server I get the following exception

{
“logLevel”: “Error”,
“message”: “Exception occurred while processing message.”,
“eventId”: {
“id”: 3
},
“exception”: {
“type”: “System.InvalidOperationException”,
“message”: “IDX20803: Unable to obtain configuration from: ‘[PII is hidden]’.”,
“stackTrace”: " at Microsoft.IdentityModel.Protocols.ConfigurationManager`1.GetConfigurationAsync(CancellationToken cancel)\r\n at Microsoft.AspNetCore.Authentication.JwtBearer.JwtBearerHandler.HandleAuthenticateAsync()"
},
“app”: {
“name”: “Squidex”,
“version”: “1.0.0.0”,
“sessionId”: “c211f2ee-8b8c-4bcb-b3ff-e1bc81b80daa”
},
“web”: {
“requestId”: “928e6293-1bad-40f9-a039-f7aeb54b50a0”,
“requestPath”: “/apps”,
“requestMethod”: “GET”,
“routeValues”: {
“area”: “Api”,
“action”: “GetApps”,
“controller”: “Apps”
}
},
“timestamp”: “2019-08-29T18:08:19Z”,
“category”: “Microsoft.AspNetCore.Authentication.JwtBearer.JwtBearerHandler”
}

I’m wondering If I have to install “squidex-identity” or could it be related to node.js. I really like the Squidex project and would like to explore it further. I would apreciate any help that you could offer

Thanks

Expected behavior

Minimal reproduction of the problem

Environment

  • [ ] Self hosted with docker
  • [X] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]

Browser:

  • [X ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:


#2

Hi,

can you turn this setting on: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L413

Then restart squidex, try it again and send me the logs.


#3

Good morning Sebastian,

I set “showPII”: true and restart squidex. The log apears to be too large to add to this post. Is there another way of sending the log or is there an entry on the log that your are looking for?

Thanks


#4

Google Drive, Dropbox, any other service to share files? :wink: