Import schema content issues

I have…

  • [ ] Checked the logs and have provided the logs if I found something suspicious there

I’m submitting a…

  • [X] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

We’re experiencing an CLI issue in version 4.4. (self-hosted) where importing from csv or son is not working.

By using the command ‘sq content export’ we are able to export perfect structures of the data including the id in both csv and json.

We synchronized the schema so we’re sure the schema we in the other app we want to import to is identical.

The CLI client user is Owner in both apps.

By running this command:
sq content import users usersexportfile.json --fields=id,userFirstName=userFirstName --format=JSON

We always get::

Imported: 0. Completed.

If we try to export to CVS we get this exception when trying to import the data in the other app schema:
Error: CsvHelper.BadDataException: You can ignore bad data by setting

We get this even when we strip down the import data load from 1000 records to 1 and ensure the data in this record is good.

Expected behavior

Expected to be able to import large amount of schema data and get a better understanding why no data is being imported by json and maybe a field reference for the csv exception so we know why we get the exception.

Minimal reproduction of the problem

Environment

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [X] Self hosted with other version
  • [ ] Cloud version

Version: [4.4]

Browser:

  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [X] Edge

Others:

Unfortunately the export is not compatible with the import feature for JSON files, I don’t remember why.