[IMPLEMENTED] Docker compose without Lets Encrypt


#1

Yesterday I tried to setup Squidex on my local machine using the docker compose files from the squidex-docker repo.

I noticed all of them use lets encrypt which makes it impossible to run squidex on localhost.

I then had to clone the repo, install all the nodejs dependencies, build with sass, and finally install mongo as a windows service.

Since the rebuild sass step messes with your env variables and what not I did not think this is a nice solution.

So what I would like instead is to install Squidex on localhost by only running containers. Minimum would be Squidex and Mongo images.

Has this been done already only that I haven’t looked in the right place?


#2

Have you tried the “-noproxy” compose files?


#3

Yes.
With http.
Still forces you over to https. Seems to do with identity server.
Couldn’t make it work with that compose file.


#4

It depends on the config:


#5

Yes, I set https to false in the .env file but it still didn’t work.


#6

Have you cleared your browser cache? It is a permanent redirect, perhaps the browser has forwarded you.


#7

Yes, I think I tried that too… don’t remember now but 99% sure I tested that… I also tried incognito mode in Chrome… no luck there either.


#8

I am 100% sure that Squidex and identity server do not enforce it, if the settings is false.


#9

Thanks, will try again.
Could be HSTS (forces HTTPS) in Chrome giving me trouble again.
It caches localhost and you have to manually remove it.


#10

It was indeed a Chrome issue. Stupid browser. :slight_smile:
Thanks Sebastian, sorry for wasting your time.


#11