How I configure Squidex on Virtual Directory


How I configure Squidex to run on Virtual Directory ?


Rodolpho Sá

This is the job of your frontend server like IIS, nginx or so.

I’m using a docker image (squidex/squidex:4.0.0-beta1).
Can I configure this in some environment variables in my squidex.yaml ?


No, sorry. It would not work, you need a frontend HTTP server for that.

1 Like

Hi @Sebastian,

I just want to re-open this question from @rhgs because I have just installed the last available release and I’m having problems setting Squidex in a Virtual Directory (IIS).

url : h**ps://myserver/Fileshare

I had installed Squidex before on my Development machine (localhost) and everything was fine. After all my tests I moved on to setup a proper server and installed Squidex on a stand alone IIS server. The virtual folder name selected was Fileshare and at first everything looked ok but :

  1. Created an APP named sandbox
  2. Created a schema called file
  3. Tried to create a field and got an error. Pushed F12 for developer console and I was getting a 404 on url : h**ps://myserver/Fileshare/Fileshare/api/sandbox…
  4. It was clear that the Fileshare virtual directory name was being attached twice.

Because of this I tried to go into the swagger definition docs site and got another 404 :

  1. This time the url was absent of the Fileshare virtual directory name like this : h**ps://myserver/api/content/sandbox/docs

To ckeck if everything was ok with my installation I just changed the IIS configuration to provide a website on port 8080 and publish Squidex on the root folder. Everything is working fine.
my current url : h**ps://myserver:8080/

Looks like there is problems on the relative paths for some urls on squidex when installed in a virtual directory.

Virtual Directory Settings :
“urls”: {
* The url where your squidex installation is available at.
“baseUrl”: “h**ps://myserver/Fileshare”

Root Folder Settings:
“urls”: {
* The url where your squidex installation is available at.
“baseUrl”: “h**ps://myserver:8080/”

You could be right, I have checked it a while ago and it was working, but never with .NET Core 3.0 so far.

I can have another look, but it does not have the highest priority. I would just use a subdomain. PRs are also very welcome :wink:

:+1: It is my intention :wink:

1 Like

PR or subdomain? :wink:

PR :wink:
I’ll have to make a deep dive on the source to familiarize myself with the Squidex architecture and namespaces.

1 Like