Hosting Squidex Locally - Error

Please guys I am trying to host squidex locally on mac and check the platform.
Please I am not able to run it :frowning:
1.Running Docker locally.
2. Installed Certificates
3. And error always popups when I start backend.

4. Running frontend on the localhost:3000 gives me screen below and any time I click the login popup pops and disappears immediately.

Please would you advise steps to host it locally step by step? I am sure I am missing smt.

Tried to connect to mongodb using “Mongo Compass”
but not sure what to put into connection string :frowning:


If you use a local mongodb without username and password you can use the defaults, otherwise your connection string should be okay, but I am not sure if you have not to use authSource= admin or so.

thanks a lot for the answer pls how should the connection string look like? Please what are the defaults? I tried as well mongodb://@localhost:27017 but compass asks me “no user name provided”. Wherefrom do I take username and password?

How have you installed mongodb?

I downloaded your docker and running it.

That should just work, you do not need username and password, just the default connection strings that are already configured.

Btw: Use https://localhost:5001 as describe in the docs:

Many thanks I followed this. Basically what i did is just downloading squidex-master and docker. Running docker and running both FE and BE. Is there some setting for clustering i can adjust? Would love to try squidex love the idea of using orleans.

A timeout occured after 30000ms selecting a server using CompositeServerSelector{ Selectors = MongoDB.Driver.MongoClient+AreSessionsSupportedServerSelector, LatencyLimitingServerSelector{ AllowedLatencyRange = 00:00:00.0150000 } }. Client view of cluster state is { ClusterId : “1”, ConnectionMode : “Automatic”, Type : “ReplicaSet”, State : “Connected”, Servers : [{ ServerId: “{ ClusterId : 1, EndPoint : “Unspecified/localhost:27017” }”, EndPoint: “Unspecified/localhost:27017”, ReasonChanged: “Heartbeat”, State: “Connected”, ServerVersion: 4.4.3, TopologyVersion: { “processId” : ObjectId(“603407d8b8de424adebb28af”), “counter” : NumberLong(0) }, Type: “ReplicaSetGhost”, WireVersionRange: “[0, 9]”, LastHeartbeatTimestamp: “2021-02-22T19:40:53.4876280Z”, LastUpdateTimestamp: “2021-02-22T19:40:53.4876290Z” }] }.

Can you show me the yaml? Perhaps I have done something wrong.

thanks this is printscreen of mongo yaml.

Can yoju remove the “–replSet -rs0” part and restart with docker-compose up -d?

yes works for me :slight_smile: thanks

1 Like