Focuspoint on image ignored

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I have a copy of this ticket [SOLVED] Asset Service: cropping/resizing breaks image.

Example with my files;

Expected focuspoint url:

Expected behavior

Minimal reproduction of the problem

Set focus point on an asset, but no results when adding ?width=200&height=200 to the asset url.
Am i missing an extra parameter? Does this only work for certain image extentions?


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [X] Cloud version


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Works for me …

Perhaps a caching issue on your side?

But this is not on the right spot. The focus point is somewhere else. (little below that)
And i dont think its caching since i tried force=true aswell.

Your link seems to be right, because the 100 height stays in the middle. But if you use 300 x 300 its way off.

Now i see it, I will have a look.

Locally it works, have you tried it without CDN and can you provide me your app name?

Appname; hakron-nl-development

Focuspoint bottom left.

But this seems to work. The endpoint on the asset CDN without the ID is also deprecated. It can happen that the wrong image is retrieved when they share the ID.


Seems the CDN doesn’t pick it up very quickly. And since its deprecated we won’t use it. The other url seems to work now. Thanks.

Have you ever created or cloned your app? If this is the case, then two assets share the same ID. Therefore the one URL without the app has very likely picked the wrong asset, without a focus point set.

Yes we did. And thats why you asked me about the appname ofcourse :slight_smile:. Because our assetId was used in multiple apps probably.
We have different environments (dev / test / staging / prod) and we sometimes push content/assets to other envs using CLI. But now atleast I know what the problem is and how to avoid it.

1 Like