Filtering by tags through ODATA


I’m trying to filter by tags through ODATA filtering, but keep getting syntax error.

My filter looks like this: $filter=data/app-tags/da in (‘tag1’).

Am i doing something wrong? i can’t see the tag field in the query editor either

This should work. But you can also use eq operator.

Which version do you use? I have tested it locally and in the cloud and both works for me. But you are right, it is not part of the query editor.

I’m using 3.5.0.

I keep getting:

“message”: “Query $filter clause not valid.”,
“details”: [
“Syntax error at position 9 in ‘data/app-tags/da in (tag1)’.”
“statusCode”: 400

Okay, it works in 4.0.3 and up, I will see if I can make a patch.

1 Like

I just upgraded to 4.0.3, but i still get the same error :confused:

Should it work with ODATA?

Sorry, the problem is the underscore in your field name.

From docs:

Please also note that dash (-) characters are not allowed in OData and that you have to use underscore instead. This restriction does not exist in JSON queries.