Fields Default Values do not work

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [ x ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]


  • [ x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

version 5.8.0

There is no description and nothing. I need more information.

I add asset field and try set Default value in Validation tab. In Content Tab I see empty field. I try do the same with String type field and see the same result. In components I see the same result too. Maybe I misunderstood something or something was broken in later version.

The default value for asset types must be an existing asset id. I should add a hint for that.

Agree about hint. Case with existing asset id I also tried. I have the same result

Tried with simple string field. Tried restarting the server in case of a cache problem. Nothing is changed

I cannot reproduce it. The default values are only applied when a new content is created.

Is it expected to be able to use default values in existing content in future?

No, because how to differentiate whether a field should be “undefined” by purpose or not?