Failed to proxy the request to https://localhost:3000/, because the request to the proxy target failed

I have downloaded sourcecode of squidex 6.x.
Run frontend
and when I run backend and try to access https://localhost:5001:
Getting below error:

{
  "logLevel": "Error",
  "message": "Connection id \u00220HMM0GE8VOPAG\u0022, Request id \u00220HMM0GE8VOPAG:00000002\u0022: An unhandled exception was thrown by the application.",
  "eventId": {
    "id": 13,
    "name": "ApplicationError"
  },
  "connectionId": "0HMM0GE8VOPAG",
  "traceIdentifier": "0HMM0GE8VOPAG:00000002",
  "timestamp": "2022-11-07T05:51:47Z",
  "app": {
    "name": "Squidex",
    "version": "1.0.0.0",
    "sessionId": "0c0fd08e-dc38-4716-805a-100775098afe"
  },
  "web": {
    "requestId": "00-41b4aa768781234a399882ddf564521c-88cfeadf2bff7bae-01",
    "requestPath": "/",
    "requestMethod": "GET"
  },
  "category": "Microsoft.AspNetCore.Server.Kestrel",
  "exception": {
    "type": "System.Net.Http.HttpRequestException",
    "message": "Failed to proxy the request to https://localhost:3000/, because the request to the proxy target failed. Check that the proxy target server is running and accepting requests to https://localhost:3000/.\n\nThe underlying exception message was \u0027The SSL connection could not be established, see inner exception.\u0027.Check the InnerException for more details.",
    "stackTrace": "   at Microsoft.AspNetCore.SpaServices.Extensions.Proxy.SpaProxy.PerformProxyRequest(HttpContext context, HttpClient httpClient, Task\u00601 baseUriTask, CancellationToken applicationStoppingToken, Boolean proxy404s)\r\n   at Microsoft.AspNetCore.Builder.SpaProxyingExtensions.\u003C\u003Ec__DisplayClass2_0.\u003C\u003CUseProxyToSpaDevelopmentServer\u003Eb__0\u003Ed.MoveNext()\r\n--- End of stack trace from previous location ---\r\n   at Squidex.Hosting.Web.HtmlTransformMiddleware.InvokeAsync(HttpContext context)\r\n   at Squidex.Web.Pipeline.SetupMiddleware.InvokeAsync(HttpContext context, IUserService userService) in D:\\Biren\\Tarento\\ci-boost\\squidex\\backend\\src\\Squidex.Web\\Pipeline\\SetupMiddleware.cs:line 41\r\n   at Squidex.Areas.Frontend.Middlewares.NotifoMiddleware.InvokeAsync(HttpContext context) in D:\\Biren\\Tarento\\ci-boost\\squidex\\backend\\src\\Squidex\\Areas\\Frontend\\Middlewares\\NotifoMiddleware.cs:line 38\r\n   at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)\r\n   at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context)\r\n   at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)\r\n   at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context)\r\n   at NSwag.AspNetCore.Middlewares.OpenApiDocumentMiddleware.Invoke(HttpContext context)\r\n   at Squidex.Web.Pipeline.LocalCacheMiddleware.InvokeAsync(HttpContext context, ILocalCache localCache) in D:\\Biren\\Tarento\\ci-boost\\squidex\\backend\\src\\Squidex.Web\\Pipeline\\LocalCacheMiddleware.cs:line 26\r\n   at Microsoft.AspNetCore.Localization.RequestLocalizationMiddleware.Invoke(HttpContext context)\r\n   at Squidex.Web.Pipeline.RequestLogPerformanceMiddleware.InvokeAsync(HttpContext context, ISemanticLog log) in D:\\Biren\\Tarento\\ci-boost\\squidex\\backend\\src\\Squidex.Web\\Pipeline\\RequestLogPerformanceMiddleware.cs:line 36\r\n   at Microsoft.WebTools.BrowserLink.Net.BrowserLinkMiddleware.ExecuteWithFilterAsync(IHttpSocketAdapter injectScriptSocket, String requestId, HttpContext httpContext)\r\n   at Microsoft.AspNetCore.Watch.BrowserRefresh.BrowserRefreshMiddleware.InvokeAsync(HttpContext context)\r\n   at Microsoft.AspNetCore.Server.Kestrel.Core.Internal.Http.HttpProtocol.ProcessRequests[TContext](IHttpApplication\u00601 application)"
  }
}

Please format the code properly (I am so tired too mention it every time :frowning: )

Ensure that:

@Sebastian: Frontend is already running with npm I && npm start
and Certificates are also there, I am running with VS 2022.

even when I heat https://localhost:3000, it showing login screen.
But not showing with https://localhost:5001

From the exception it seems to be a problem with the certs. Have you restarted VS after the installation?

Yes, I already restarted VS even restarted system also.
But facing same issue.

Do you get a cert warning in the browser for localhost:3000?

no not getting any cert error, check attached screen of https://localhost:3000

In console getting below error:
Refused to apply style from ‘https://localhost:3000/scripts/outdatedbrowser/outdatedbrowser.min.css’ because its MIME type (‘text/html’) is not a supported stylesheet MIME type, and strict MIME checking is enabled.

Failed to load resource: the server responded with a status of 404 (Not Found)

Refused to execute script from ‘https://localhost:3000/scripts/outdatedbrowser/outdatedbrowser.min.js’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.

When I published code and bind with IIS, its working fine.
I am facing this issue only when I am debugging source code.

The header should not look like this. Does not look like the certs are installed properly.