Fail to edit the maximum of items of each query

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I want to change the number of return result of query. I found the maxResults in the appsettings.
But my squidex still return 200 results after I changed it to 500.
This change worked in last week, but it fail now.

Expected behavior

Return number of the result that I set.

Minimal reproduction of the problem


  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [5.4.0]


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


I setup the squidex in kebernetes. I got the appsettings file in the pod.

How have you configured it exactly?

I changed the maxResults to 500, then save and upload to /app/appsettings.json

I would use an env variable in kubernetes.

Oh! So What’s the name of it? contents__maxResults?

Yes, exactly…if you upload a file the setting can get lost on restart.

I will try it later, thanks.