Disable RequestLogs

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [X] Documentation issue or request

Current behavior

As you can see the collection for request log is growing pretty fast.
image

Is there a way to disable request logs?

Expected behavior

Minimal reproduction of the problem

Environment

App Name:

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [X] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]

Browser:

  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:

see this setting: https://github.com/Squidex/squidex/blob/master/backend/src/Squidex/appsettings.json#L276

1 Like

Thanks, I was just about to answer my own question. However, I also saw you said all logs go to Stdout, so I am a bit confused. I guess we have 2 options now?

Yes, the normal logs go to stdout. But in the app dashboard you have the option to download the request logs of your app. This is the setting to turn this off.

1 Like