Custom Roles permissions issue

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I created a custom role with these permissions :|create|update|create|update

The list of theses contents are well displayed but when I tryed to access to one of these contents, I have a popup " Unsaved changes
You have unsaved changes.
When you close the current content view you will lose them.
Do you want to continue anyway?"

If I click “NO” the popup is closed, but when I tried to save my content I have a error (
If I click “YES” I have the error

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [X] Cloud version

Version: [VERSION]


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Do you see the dialog also when you have owner permissions?

No it’s working well if the user role is OWNER

1 Like

Can you add me as a contributor to this app?

Do you have references in the schema? I think what could have happened is this:

The UI tries to query the references, but it does not receive contents for all schemas because of missing permissions. Then it clears the invalid references and therefore the content has changed.

What you want is this permission as well:


Yes I have several references, i tried to add a “content.*”, but still not working

See my answer above.

Still not working, the problem persist. I tried to add all the kinds of content autorizations.

Do you know whether the references show everything they should? Could also be the assets.

1 Like

Nice call, it was the assets
It’s working now :wink:

Thank you @Sebastian

1 Like