query takes 90 seconds

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [x ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When I POST the query below it takes up to 90 seconds, and yesterday it took 7.

query {
    queryListingContents {
      flatData {

There are 200 odd objects

Expected behavior

It should take 7 seconds at most

Minimal reproduction of the problem

Run query against my instance


App Name: hanmer

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x ] Cloud version



  • [x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [x] Chrome (iOS)
  • [ ] Firefox
  • [x] Safari (desktop)
  • [x ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

This was working fine yesterday, has something changed? other queries run fine.

If I run the query inside squid dashboard it’s instant.
If I run it with insomnia it’s 90 seconds.

Here’s some guff from chrome… 90 seconds

Request URL:
Referrer Policy: strict-origin-when-cross-origin
:method: POST
:path: /api/content/hanmer/graphql
:scheme: https
accept: */*
accept-encoding: gzip, deflate, br
accept-language: en-GB,en-US;q=0.9,en;q=0.8
content-length: 156
content-type: application/json
origin: http://localhost:3000
referer: http://localhost:3000/
sec-fetch-dest: empty
sec-fetch-mode: cors
sec-fetch-site: cross-site
user-agent: Mozilla/5.0 (iPhone; CPU iPhone OS 13_2_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.3 Mobile/15E148 Safari/604.1

The Squidex API makes a lot more things when the call is for the dashboard then for any other client, so I would not expect that it is faster over the dashboard.

Could be an issue with your phone.

It was working yesterday though. In fact I have an app on the app store that uses this and it has also started to fail. It fails when I use curl too. Can you please look into this, is there a paid support option? doesn’t load either from here

It’s not the actual query that’s taking the time, it’s something else. It just hangs there for exactly 83 seconds every time

This is fixed now after you “restarted the secondary database instances” :slight_smile:

1 Like