Base docker setup has Errored GraphQL

I am currently using the docker compose standalone version and everything was going well with a basic setup (no OAuth info or anything like that, just admin info in environment).

However, when I go to the GraphiQL interface it gives me this error:

TypeError: Cannot read property 'data' of null
    at r.invoke (
    at Object.onInvoke (
    at r.invoke (
    at (
    at r.invokeTask (
    at Object.onInvokeTask (
    at r.invokeTask (
    at e.runTask (

Is there some sort of asset pipeline or something that I need to re-run in order for GQL to work? I had a similar issue on the production cloud version where my GQL didn’t update immediately so that is why I am wondering if there is some sort of cron or something that generates the schema?


The graphql schema is cached for 10 minutes because of performance reasons, but besides that there i nothing you should need to run.

Thanks Sebastian, however I have been waiting since last night and it still is showing that error. I tried rebuilding the images with docker-compose up -d --build --force but nothing happened. I still go to the GraphiQL tab in the API and it shows the same error. Any thoughts? Can I force clear the cache for it?

Can you check if the docker-compose file has the current version? Can you check the network tab in chrome?

Hi, it is my fault. I introduced a bug in a recent version this weekend. Going to fix it now.

Thank you so much Sebastian!

I fixed it and deployed a new docker version.

Pulled and rebuilt… Seems to be working. Thanks!

Awesome :slight_smile: … Going to close this topic now.