Backup restore fails: Cannot download the archive. Got status code:

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ x ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Trying to restore a backup fails with error Cannot download the archive. Got status code: .

Server Logs:

    "logLevel": "Error",
    "action": "restore",
    "status": "failed",
    "operationId": "728247f9-69f0-4cc0-996b-d927d40741bb",
    "url": "https://<serverurl>/api/assets/tmp/4584d689-fcc4-4ee3-a4e5-204ee70f46ac/",
    "timestamp": "2022-05-10T09:01:08Z",
    "app": {
      "name": "Squidex",
      "version": "",
      "sessionId": "869d21a2-7835-4f84-9afb-d9a6eaf83ed0"
    "exception": {
      "type": "Squidex.Domain.Apps.Entities.Backup.BackupRestoreException",
      "message": "Cannot download the archive. Got status code: .",
      "stackTrace": "   at Squidex.Domain.Apps.Entities.Backup.TempFolderBackupArchiveLocation.OpenReaderAsync(Uri url, DomainId id) in /src/src/Squidex.Domain.Apps.Entities/Backup/TempFolderBackupArchiveLocation.cs:line 54\n   at Squidex.Domain.Apps.Entities.Backup.RestoreGrain.DownloadAsync() in /src/src/Squidex.Domain.Apps.Entities/Backup/RestoreGrain.cs:line 297\n   at Squidex.Domain.Apps.Entities.Backup.RestoreGrain.ProcessAsync() in /src/src/Squidex.Domain.Apps.Entities/Backup/RestoreGrain.cs:line 155"

Expected behavior

Backup should restore

Minimal reproduction of the problem

I’ve tried restoring the same backup which I took from from another environment running the exact same version of squidex. I’ve tried it with http and with https in the url
The file size 8.5MB and to account for that I updated the environment variable ASSETS__MAXSIZE=10485760

I was able to upload the backup to a tmp project I created to test that the asset size was working as expected.


App Name: con-fusion

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [x] Self hosted with other version (Helm chart)
  • [ ] Cloud version



  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Can you give me the link? I can improve the error message, seems to be a non-http issue, but I guess somehow the squidex node cannot communicate with your instance, where you host the backup.

I would connect to the container with kubernetes and try to ping the domain.

Hi, you sent me down the right path, we had a random dns related issue and so this is resolved now. thank you

1 Like