API doesn't work after ssl cert change

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

API doesn’t work after SSL certificate change

Expected behavior

API should work correctly

Minimal reproduction of the problem

Today, my SSL cert has expired and I changed it to the new one
But I can’t see pictures, text, and content published throughout Squidex


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version
  • [x] Kubernetes

Version: image squidex/squidex:5.8.0


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [x] Safari (iOS)
  • [ ] IE
  • [ ] Edge


I deleted and created images again
it’s weird but it’s helped me

can you explain why assets went broken after ssl cert has been changed?

For example, I uploaded again pictures of some heads and now it works well

I have no idea what the reason could be. SSL is not handled by Squidex directly.

it’s weird
assets are destroyed
now my team create assets from the beginning

Have you restarted Squidex? Do you mount the assets to an external volume? Where do you host them?

yes, i’ve restarted pod with squidex 2 or 3 times
no, assets stored in default storage created by helm chart

Okay, this is a problem with the helm chart. Squidex supports several store types: https://github.com/Squidex/squidex/blob/master/backend/src/Squidex/appsettings.json#L284

The default is “Folder” which is not a persistent store in your case. I would either set it to MongoDB or a cloud provider.

Helm chart install mongodb by default
Screenshot 2021-10-28 at 16.08.19

Yes, but MongoDB is not used to store assets.

it’s very very weird:)
any way thank you for help!

Yes, I know. I have already fixed it. I have not seen it yet , sorry.

oh, I have one more question
how can I update the version of squidex to latest using helm?
helm upgrade squidex squidex/squidex doesn’t work

I have no idea, honestly, I am not a helm user.

okay, thank you anyway !

1 Like

my problem was solved after I added NODE_TLS_REJECT_UNAUTHORIZED=0
my website goes back down

1 Like