Restore Application has Failed

I have…

  • [X ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem

I try to restore my https://squidex-cms.sennit.com.br/api/apps/site-sennit/backups/860c23d4-f19e-4702-a2e0-25a8a43f999b backup with new app name and resulted this:

2020-05-13T14:14:02Z: Started. The restore process has the following steps:

2020-05-13T14:14:02Z: * Download backup

2020-05-13T14:14:02Z: * Restore events and attachments.

2020-05-13T14:14:02Z: * Restore all objects like app, schemas and contents

2020-05-13T14:14:02Z: * Complete the restore operation for all objects

2020-05-13T14:14:02Z: Downloading Backup

2020-05-13T14:14:12Z: Downloaded Backup

2020-05-13T14:14:12Z: Creating Users

2020-05-13T14:15:31Z: Reading 2027 events and 169 attachments completed.

2020-05-13T14:15:31Z: Restored Apps

2020-05-13T14:15:31Z: Restored Assets

2020-05-13T14:15:32Z: Restored Contents

2020-05-13T14:15:32Z: Restored Rules

2020-05-13T14:15:32Z: Restored Schemas

2020-05-13T14:15:32Z: Completed Apps

2020-05-13T14:15:32Z: Completed Assets

2020-05-13T14:15:32Z: Completed Contents

2020-05-13T14:15:32Z: Completed Rules

2020-05-13T14:15:32Z: Completed Schemas

2020-05-13T14:15:32Z: Failed with internal error

Environment

  • [ X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]
4.3.0

Browser:

  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [X ] Edge

Others:

After that, I try to restore again and get a message : application name already exists.

Important to say that the new application is not visible to me, but is visible to another user but he can not make any modifications to it or archive it

Tks.

I cannot help with logs. You can probably only fix it in the DB for now.

Hi Sebastian!

Looking at the log, you could tell what was missing for me to correct in the DB ?
What was the next step in the restore process?

Tks

You can try to rebuild the indexes:

1 Like