How to make a full export to Algolia manually trigerred


I’m very interested in the Algolia integration and I was wondering whether it’s possible to export the current of a Squidex instance into Algolia using the rules. I’ve seen that a rule can be executed manually, so my idea it’s just to create two rules, one for the content that is already in Squidex and one for the new content. For the first rule, it’ll be executed manually only one time, so the idea is to export the current data to Algolia. I’ve set up the “Populate Algolia index” with the minimum required data: “Application Id”, “Api Key” and “Index Name” and after executing it I don’t see the content in Algolia.
Maybe I’m missing something.



you can rerun a rule from beginning.

  1. If you press “Run”, the events are replayed, so a content might be pushed several times to Squidex.
  2. If you press “Run with latest states” it fetches all content items and pushes the latest versions only.


Hi @Sebastian,

Thank you very much for your help. Unfortunately, I was not able to make it works.

This is the rule configuration:

And when I press the run button, this is the log that is printed:

As I said earlier, maybe I’m missing something or doing something wrong. I have checked that te Application ID and API key are the correct ones.


The AlgoliaAction only makes sense with content events, because you wanna push contents to Algolia in the original format or a custom format.

Therefore your manual trigger does not work. Of course you can implement your own indexing process and just trigger a webhook here which fetches the content from Squidex then and pushs it to Algolia, but I do not recommend it.

Long answer short: Create a rule like this “If Content Changed then Populate Algolia Index”

Hi @Sebastian,

I’m trying the “Content changed” rule to populate the Algolia index but I’m facing some issues. The rule now is like:

And the configuration is like the former one. With only this configuration I’m getting the error:

I have seen that there is a similar question: [SOLVED] Algolia Rule throws exception. So I’ve tried to add this configuration as a test:

But I’m getting the same “data should not be an IEnumerable/List/Collection” error. When I try it out in the simulator, it seems that is working:

So I’m not sure if I’m missing some configuration.


This looks like a bug, I will have a look.

Can you create a bug report?

Yes, I’ll create it :wink: Thanks!

I have created this one: "data should not be an IEnumerable/List/Collection" error in a Content Changed rule to Populate Algolia Index